Arduino Uno + Seeedstudio Bluetooth shield issue

Anything Arduino

Arduino Uno + Seeedstudio Bluetooth shield issue

Postby HarryJenkins » Thu Feb 08, 2018 3:42 am

Hi,

I have a problem setting up bluetooth communication between my samsung galaxy S2 and seeedstudio bluetooth shield mounted on an arduino Uno. I closely followed the tutorial to connect my module with my cellphone. I'm able to send data using SPP app from my "arduino uno + BT module" to my android phone using the Android IDE 1.0 terminal. On the other hand when I send data from my android phone to the BT module I receive strange characters like if the baudrate was incorrectly set.
I double checked everything but I can hardly find any clue about what's going on. I strictly followed the tutorial and did not edit the Slave mode sample code (the one with NewSoftSerial lib dependancies) which I uploaded to my board.

When I connect my phone to the module here is what I see on the terminal:
The slave bluetooth is inquirable!
„•¡j*UˆªJš4)ÿ„¡§gS¡(z­ÿ„•¡j*UŠªJ¢4)ÿ

instead of the expected :
The slave bluetooth is inquirable!
+BTSTATE:3
CONNECT:OK
+BTSTATE:4

Does anybody have the same issue ? Can somebody help me please ?
Thanks






I didn't find the right solution from the internet.
References:
http://seeedstudio.com/forum/viewtopic.php?f=23&t=3042

B2b Digital Marketing Examples
HarryJenkins
 
Posts: 1
Joined: Tue Feb 06, 2018 12:46 am

Return to Arduino

Who is online

Users browsing this forum: No registered users and 1 guest

cron