USB Issues, HD, Arduino

Anything Arduino

USB Issues, HD, Arduino

Postby spadekevin » Tue Jun 26, 2018 6:08 am


I have a model 3 that for the past few months I have been using as an Arduino programmer. The Arduino Uno has been connected to the Pi and reading temperatures and then sending the data serially to the Pi which (using a Python program) commits the data to a MySQL database. It has worked fine.
I decided that it was time to connect a hard drive so that the database does not have to be stored on the SD card. I could not get the HD to show up (in the dmesg) until I unhooked the Arduino. Then the HD showed up (as /dev/sda) and I was able to mount it (as /mnt/hd). That worked fine.
Now I cannot get the Arduino to work. With or without the HD connected there is no /dev/ttyUSB0 that the Arduino used to be connected to. Also in the Arduino IDE the select serial port is greyed out.
What do I need to do to get both devices working?

Please help.

I didn't find the right solution from the Internet.

References:- ... p?t=178293

Posts: 1
Joined: Mon Jun 25, 2018 11:50 pm

Return to Arduino

Who is online

Users browsing this forum: No registered users and 1 guest